Question : Cisco QOS to prioritize voice

Hello,
I need some assistance applying QOS to voice on some MPLS VLAN links.  The WAN links transport SIP between sites.  The LAN transports SIP to only one device at each site (an NEC hybrid PBX).  Routers are Cisco 2800 and 1800 series, switches are Cisco 3600 series.

Here is one of my configs with some QOS commands that my NEC installer asked me to put in place.  I don't know Cisco QOS commands at all, so I have no idea if they are correct.

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAR_ROUTER1
!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-12c.bin
boot-end-marker
!
card type t1 0 0
logging buffered 51200 warnings
enable password xxxxx
!
no aaa new-model
no network-clock-participate wic 0
!
!
ip cef
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 secret 5 $1$dLcB$fcKqgHJOzrRmi26DArDuq0
!
!
controller T1 0/0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24
 description Point-to-point T1 to Presque Isle
!
controller T1 0/0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24
 description Point-to-point T1 to Houlton
!
class-map match-all VOICE-TRAFFIC
 match ip dscp ef
!
!
policy-map VOICE
 class VOICE-TRAFFIC
  set ip dscp ef
  priority 600
!
!
!
!
interface FastEthernet0/0
 description Connected to MPLS Circuit
 no ip address
 duplex full
 speed 100
 service-policy output VOICE
!
interface FastEthernet0/0.392
 description Presque Isle MPLS VLAN
 encapsulation dot1Q 392
 ip address 10.0.0.1 255.255.255.252
!
interface FastEthernet0/0.393
 description Houlton MPLS VLAN
 encapsulation dot1Q 393
 ip address 10.0.0.5 255.255.255.252
!
interface FastEthernet0/1
 description Connected to Caribou LAN via CAR_SWITCH1 FastEthernet0/24
 ip address 192.168.0.1 255.255.255.192
 duplex full
 speed 100
!
interface Serial0/0/0:0
 description Presque Isle T1
 ip address 192.168.0.130 255.255.255.252
 shutdown
 service-policy output VOICE
!
interface Serial0/0/1:0
 description Houlton T1
 ip address 192.168.3.1 255.255.255.252
 service-policy output VOICE
!
ip route 0.0.0.0 0.0.0.0 192.168.0.10
ip route 192.168.0.64 255.255.255.192 FastEthernet0/0.392
ip route 192.168.4.0 255.255.255.0 FastEthernet0/0.393
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

Answer : Cisco QOS to prioritize voice

Does the user profile that you are running under (at runtime) have  rights to execute program DSR596DE?

Silly things to check:  

Is the program name spelled right?  596/569 is an easy transposition, for example.
Does something in the runtime job change the library list in a way that removes your lib? When you get the error, look at the job's libl right then.


- Gary Patterson
Random Solutions  
 
programming4us programming4us