Question : Cisco Switch not configured with TACACS asks for username?

I have a Cisco 3750G that has the no AAA new-model command but still asks for username even though TACACS is not configured.

Usually when I try to SSH to a device that does not have SSH or TACACS configured  I get a connection refused message.

I can log in successfully with just a password using Telnet but the switch does not ask me for a username.

Is this just a version of code issue?

xxx#sh run
Building configuration...

Current configuration : 4401 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxx
!
enable secret 5 xxx
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
vtp mode transparent
ip subnet-zero
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 615
 name xxx
!
vlan 793
 name xxx
!
vlan 950
 name xxx
!
!
interface GigabitEthernet1/0/1
xxx
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 615,793
 switchport mode trunk
 spanning-tree portfast disable
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan615
 ip address 172.16.15.248 255.255.255.0
!
ip default-gateway 172.16.15.1
ip classless
no ip http server
ip http secure-server
!
!
!
control-plane
!
banner exec ^C



xxx

^C
!
line con 0
 password 7 xxx
line vty 0 4
 password 7 xxx
 no login
line vty 5 15
 password 7 xxx
 no login
!
end

Answer : Cisco Switch not configured with TACACS asks for username?

Appears that SSH is enabled on that box, but you don't have any method of authentication specified. It will prompt you for a user/pass, but it doesn't really check it against anything.

Check out this link for some troubleshooting steps *(it's where I got the show commands above)
http://www.cisco.com/en/US/tech/tk583/tk617/technologies_tech_note09186a00800949e2.shtml#tbs

The link suggests you delete the RSA key pair, which then disables SSH
Random Solutions  
 
programming4us programming4us