Question : detect startmenu sortcuts who's target no longer exists

i have a list of shortcut's in a start menu folder ,i need to iterate the list and detect weather the shortcut's Target exists ,could somone please help me i need code examples and any references required..

foreach(FileInfo fi in fileInfos)
{
     if (!File.Exists(<fi's Target >))
     {
             fi.Delete();
      }
}

Answer : detect startmenu sortcuts who's target no longer exists

Building configuration...

Current configuration : 1714 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname xyz
!
boot-start-marker
boot-end-marker
!
enable secret 5 ?!?!@#?!?#?!@#?!@#?!?@#?!@#?!@?#?@!#?!@#?
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip domain name xyz.com
ip ssh time-out 60
ip ssh authentication-retries 5
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all VOICECLASS
 match  dscp ef
!
!
policy-map VOICEQOS
 class VOICECLASS
  priority 1000
 class class-default
  fair-queue
!
!
!
!
interface FastEthernet0/0
 ip address 11.11.11.51 255.255.255.248
 ip nat outside
 duplex auto
 speed auto
 service-policy output VOICEQOS
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 bridge-group 1
!
interface FastEthernet0/3/0
!
interface FastEthernet0/3/1
!
interface FastEthernet0/3/2
!
interface FastEthernet0/3/3
!
interface Vlan1
 ip address 172.16.20.1 255.255.255.0
 ip nat inside
!
ip classless
ip route 0.0.0.0 0.0.0.0 11.11.11.54
!
!
no ip http server
no ip http secure-server
ip nat inside source static 172.16.20.49 11.11.11.49
ip nat inside source static 172.16.20.50 11.11.11.50
ip nat inside source static 172.16.20.52 11.11.11.52
ip nat inside source static 172.16.20.53 11.11.11.53
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
!
voice-port 0/2/0
!
voice-port 0/2/1
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 transport input telnet
Random Solutions  
 
programming4us programming4us