Question : Web server in DMZ to access SQL server on INSIDE

I am trying to give my web server in the DMZ access to a backend sql server on port 1433. When I trace the packet it is using the global pool and the packet drops. Can someone give me advice on how to get around this?

Thanks in advance
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
22:
23:
24:
25:
26:
27:
28:
29:
30:
31:
32:
33:
34:
35:
36:
37:
38:
39:
40:
41:
42:
43:
44:
45:
46:
47:
48:
49:
50:
51:
52:
53:
54:
55:
56:
57:
58:
59:
60:
61:
62:
63:
64:
65:
66:
67:
68:
69:
70:
71:
72:
73:
74:
75:
76:
77:
78:
79:
80:
81:
82:
83:
84:
85:
86:
87:
88:
89:
90:
91:
92:
93:
94:
95:
96:
97:
98:
99:
100:
101:
102:
103:
104:
105:
106:
107:
108:
109:
110:
111:
112:
113:
114:
115:
116:
117:
118:
119:
120:
121:
122:
123:
124:
125:
126:
127:
128:
129:
130:
131:
132:
133:
134:
135:
136:
137:
138:
139:
140:
141:
142:
143:
144:
145:
146:
147:
148:
149:
150:
151:
152:
153:
154:
155:
156:
157:
158:
159:
160:
161:
162:
163:
164:
165:
166:
167:
168:
ASA Version 8.0(4) 
!
hostname asa5510
enable password lWb1GAiWBP7tSzHx encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name x.x.x.x Canam
name 10.167.87.17 CRM-SQL-PROD
name 10.30.30.60 DMZserver
name x.x.x.x DMZpublic
name x.x.x.x VIMSblue1
dns-guard
!
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address x.x.x.x 255.255.255.252 
!
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 10.167.68.8 255.255.255.0 
!
interface Ethernet0/2
 nameif dmz
 security-level 50
 ip address 10.30.30.1 255.255.255.0 
!
interface Ethernet0/3
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Management0/0
 nameif management
 security-level 100
 ip address 192.168.100.1 255.255.255.0 
 management-only
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group defaultdns
 domain-name 
object-group service sql tcp
 port-object eq 1433
object-group service DM_INLINE_TCP_1 tcp
 port-object eq www
 port-object eq https
object-group service FTP tcp
 port-object eq 81
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object udp
 protocol-object tcp
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
access-list outside_access_in extended permit tcp any host DMZpublic eq https 
access-list outside_access_in extended permit tcp host Canam host DMZpublic eq 3389 
access-list outside_access_in extended permit tcp host VIMSblue1 host DMZpublic eq ftp 
access-list dmz_access_in extended permit tcp host DMZserver host CRM-SQL-PROD eq 1433 
access-list dmz_access_in extended permit tcp host DMZserver any object-group DM_INLINE_TCP_1 
access-list dmz_access_in extended permit udp host DMZserver any eq domain 
access-list dmz_access_in extended permit tcp host DMZserver any eq domain 
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu management 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-625-53.bin
no asdm history enable
arp timeout 14400
global (outside) 101 interface
global (dmz) 101 10.30.30.61-10.30.30.80 netmask 255.255.255.0
nat (inside) 101 0.0.0.0 0.0.0.0 dns
nat (management) 101 0.0.0.0 0.0.0.0
static (dmz,outside) DMZpublic DMZserver netmask 255.255.255.255 dns 
static (inside,dmz) DMZserver DMZserver netmask 255.255.255.255 
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route inside 10.0.0.0 255.0.0.0 10.167.68.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication telnet console LOCAL 
http server enable
http 10.167.67.63 255.255.255.255 inside
http 10.167.67.66 255.255.255.255 inside
http 192.168.100.0 255.255.255.0 management
http 10.167.68.2 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet 10.167.67.66 255.255.255.255 inside
telnet 10.167.67.63 255.255.255.255 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.100.2-192.168.100.254 management
dhcpd auto_config outside interface management
dhcpd enable management
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
username xyz password w8Jj0AkDuu/oLhY3 encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map global_policy
 class inspection_default
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
  inspect dns 
  inspect ftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:f1ebf5fc4b169badd03a72c1733b3d3e
: end

 asa5510#

Answer : Web server in DMZ to access SQL server on INSIDE


You're on the right lines there :)

Add a root zone, a zone called "." to the DNS server in question. Then create a wildcard record (*) in that zone pointing at the IP you want.

Chris
Random Solutions  
 
programming4us programming4us