Question : Cisco Catalyst 2950

we want to open up a connection to the inside and outside world, my ISP has done this
"I have setup a reverse proxy on our revproxies listening on 131.242.175.59 and 131.242.175.60 listening on the http port (80).
I have setup DNS entries for the two domains webmail.au and contracts.au pointing to both of these addresses.
These proxies forward the traffic to 147.132.180.16 port 81. (his lotus domino server)
 
The client will need to do the redirects to the nsf files himself based on the names passed.
 
I have tried to test the connection from the proxy servers to the client server.
 
tests failed.
 
The client will need to ensure he allows access to his server 147.132.180.16 from the our proxy servers 131.242.175.3 and 131.242.175.4."

i will write down the show run, for the switch.......
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname q10
!

!
clock timezone UTC 10
ip subnet-zero
!
cluster enable q10
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
 description CITEC ADSL Router
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface FastEthernet0/2
 description CITEC to QAO-FW1-Primary (mgmt)
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
 description CITEC to QAO-FW1-Secondary (mgmt)
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/4
 description SOUL ADSL Router
 switchport access vlan 102
 switchport mode access
 speed 100
 duplex full
 spanning-tree portfast
 spanning-tree bpdufilter enable
!
interface FastEthernet0/5
 description SOUL to QAO-FW1-Primary (e0/0)
 switchport access vlan 102
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
 description SOUL to QAO-FW1-Secondary (e0/0)
 switchport access vlan 102
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/7
 description AMQLD Server
 switchport access vlan 103
 switchport mode access
 spanning-tree portfast

!
interface FastEthernet0/8
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/9
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/10
 description Magellan Server
 switchport access vlan 104
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/11
 description WEB01
 switchport access vlan 104
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/12
 description Connection to QAO_ASA_10_Primary (e0/2) (CITEC)
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/13
 description Connection to QAO_ASA_10_Secondary (e0/2) (CITEC)
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/14
 description Germes Monitoring
 switchport access vlan 106
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/15
 description Connection to QAO-FW1-Primary (e0/2)
 switchport mode trunk
!
interface FastEthernet0/16
 description Connection to QAO-FW1-Secondary (e0/2)
 switchport mode trunk
!
interface FastEthernet0/17
 switchport mode access
 spanning-tree portfast
 --More—

interface FastEthernet0/18
 description Lotus Cluster Network
 switchport access vlan 106
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/19
 description Lotus Cluster Network
 switchport access vlan 106
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/20
 description Lotus Cluster Network
 switchport access vlan 106
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/24
 description Telstra GWIP Connection
 switchport access vlan 105
 switchport mode access
 speed 100
 duplex full
 spanning-tree bpdufilter enable
!
interface GigabitEthernet0/1
 description Connection to QAO-ASA-10-Primary (e0/0)
 switchport access vlan 105
 switchport mode access
!
interface GigabitEthernet0/2
 description Connection to QAO-ASA-10-Secondary (e0/0)
 switchport access vlan 105
 --More—
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan106
 ip address 192.168.0.1 255.255.255.0
 no ip route-cache
!
ip http server
!
ip access-list extended CMP-NAT-ACL
 dynamic Cluster-HSRP deny   ip any any
 dynamic Cluster-NAT permit ip any any
access-list 60 permit 192.168.0.2
snmp-server community q
snmp-server community qa
!
line con 0
line vty 0 4
 
 login
line vty 5 15
 
 login
!
ntp clock-period 1
ntp server 172.16.0.1
!
end

kindly let me know if i have to do any firewall configuration, or should i add the IP addresses to the VLAN 104....
one of the server NIC is already connected to this switch on port 11 (i.e. VLAN 104), so should i add one more interface and VLAN port?

Answer : Cisco Catalyst 2950

By default MDatagrid doesnot allow you to modify the dataprovider.

http://www.iwobanas.com/2009/06/datagrid-with-client-side-filtering-and-searching/

"By default MDataGrid is using a local copy of data provider and doesn’t support removing/modifying items.
You can try setting copyDataProvider=false so that data provider will not be copied but I can’t guarantee that this will support deleting items."


So I changed your code of MDatagrid with copyDataProvider=false. Its working for me. But drawback will be that component won't have copy of database and filters added will be directly affecting the dataprovider.
1:
2:
3:
<controls:MDataGrid dataProvider="{myData}" copyDataProvider="false"
							width="100%"
							height="100%">
Random Solutions  
 
programming4us programming4us