Microsoft
Software
Hardware
Network
Question : Configure Cisco router with PPPoe for ADSL connection
I have a home ADSL connection with a local ISP and am trying to set one of my CISCO routers as the internet router, unfortunatly this is not working.
This is what i have done so far:
1) I connect to the adsl modem (web gui) and disconnect the pppoe. (Screenshot attached)
2) I followed the instructions here
http://www.dslreports.com/
faq/10952
and
http://www.dslreports.com/
faq/8199
This is my sh version, ip interface, and sh run.
The connections are as follows ADSL Modem goes to FA0/1 and a switch connects to FA0/0 where my pc is connected on the 192.168.16.0 /24 subnet.
Router#sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(15)T9, RELEASE SOFTWARE (fc2)
TAC Support:
http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Sat 01-Nov-03 04:43 by ccai
Image text-base: 0x80008098, data-base: 0x819C9AF4
ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)
Router uptime is 12 minutes
System returned to ROM by power-on
System image file is "flash:D12215T9.POO"
cisco 2611XM (MPC860P) processor (revision 0x300) with 125952K/5120K bytes of memory.
Processor board ID JAE0815BWKV (2727068054)
M860 processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
2 FastEthernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102
Router#
Router#sh ip int br
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.16.1 YES NVRAM up up
FastEthernet0/1 unassigned YES NVRAM up up
Virtual-Access1 unassigned YES unset up up
Dialer1 unassigned YES NVRAM up up
Router#sh run
Building configuration...
Current configuration : 1601 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
logging queue-limit 100
!
ip subnet-zero
!
!
no ip domain lookup
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
description LAN INTERFACE
ip address 192.168.16.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
description ADSL WAN INTERFACE
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
no ip mroute-cache
duplex auto
speed auto
pppoe enable
!
interface Dialer1
description ADSL WAN DIALER
ip address negotiated
no ip unreachables
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname
[email protected]
ppp chap password 0 aaaaaaaaa
ppp pap sent-username
[email protected]
password 0 aaaaaaaaa
ppp ipcp dns request accept
ppp ipcp address accept
!
ip nat inside source list NAT-ACCESSLIST interface Dialer1 overload
ip http server
ip classless
ip route 0.0.0.0 255.255.255.255 Dialer1
!
!
!
ip access-list extended NAT-ACCESSLIST
permit ip 192.168.16.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
ADSL-MODEM.jpg
(118 KB)
(File Type Details)
ADSL MODEM
Answer : Configure Cisco router with PPPoe for ADSL connection
this should fix it :)
interface FastEthernet0/1
pppoe-client dial-pool-number 1
Random Solutions
VirtualBox and multicast
How do I forward an entire url to a local IP on my network in DNS?
Haven’t setup hint root zone file, but still can see internet records
Wireless access while on wired network
asp.net need help on a parameterize search via a filter expression
A Perl Spreadsheet Problem
Decrease load time of tree in vb.net 2003
SQL Function Error - Cannot access temporary tables from within a function
Where does outlook store temporary addresses?
Coldfusion SQL how can i get the last bit field type with value 1 in the current row